Ticket #771 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

cannot access puffin over sftp again

Reported by: annesley Owned by: ed
Priority: major Milestone: Maintenance
Component: Dev server Keywords:
Cc: chris, paul, ed Estimated Number of Hours: 0.0
Add Hours to Ticket: 0 Billable?: yes
Total Hours: 0.25


not sure what happened this time. my connection to other servers is fine. i am using:


the password was accepted first time and i successfully navigated to /static

which worked until i tried to get to the transition-network-d6-32-s002-booker directory. now ssh fails also.

when i ssh in i get plenty of warnings and potential lock outs when i try various things. like trying to access /static.

Change History

comment:1 Changed 2 years ago by chris

  • Add Hours to Ticket changed from 0.0 to 0.25
  • Total Hours changed from 0.0 to 0.25

I have unblocked your IP address again. You shouldn't need to use password authentication as your ssh public key is on the server. The restrictions to the tn.ftp shell are a BOA feature. You have sudo on your personal account so you can do anything, if needs be and if you are confident that you are not going to break anything.

comment:2 Changed 2 years ago by annesley

ls, ll, cat, dirname, etc. are all locked down. by BOA i understand. this makes navigating the BOA server very frustrating and time consuming for me. does BOA come with tools that make this less painful? a FileManagement? interface that they use? a backend for Drupal control? i am essentially putting sudo before every command i use which is not good practice on a live server.

one of the main problems is that Drush makes Drupal development happy. instead of mind bleedingly hideous. and it refuses to be run as root for good reasons. so sudo doesn't help and i can't find a patch.

without Drush i cannot sort the website out if it becomes un-usable. (clear caches, un-install modules, create a backend login, etc.)

is there anyway we could circumvent BOA and allow drush to carry out the following? (there may be more!)
/usr/bin/drush: line 10: /usr/bin/dirname: Permission denied
/usr/bin/drush: line 11: cd: : No such file or directory
/usr/bin/drush: line 11: /usr/bin/basename: Permission denied
/usr/bin/drush: line 36: /usr/bin/dirname: Permission denied
/usr/bin/drush: line 94: /usr/bin/dirname: Permission denied

or should i approach these things in a different way. the problem is that i am using staging to show people the new IIRS. which is not really what i should be doing. so it's understandable that the (live) server is so locked down.

is there another public server i can use to demo dev stuff? or should i start using DYNDNS on to my laptop?

thanks for help!

comment:3 Changed 2 years ago by annesley

hold on: i think it is working with the tn.ftp account...

comment:4 Changed 2 years ago by annesley

ok, yes. have managed to run drush cc all now. all ok :D :D sorry for not getting that earlier!

is it ok for me to just use the tn.ftp account from now on?

comment:5 Changed 2 years ago by annesley

  • Status changed from new to closed
  • Resolution set to fixed

comment:6 Changed 2 years ago by ed

  • Type changed from maintenance to defect
  • Milestone set to Maintenance

moving to maintenance milestone as this is a maintenance task

Note: See TracTickets for help on using tickets.